University Crest

[wlug] Problems with 2.6.11 on FC3

 
wlug archive index About the wlug list Mailing lists home
To The University of Waikato HomepageWaikato Home > Waikato Mailing Lists > wlug Info > wlug archives
Oliver Jones oliver@d...
Sat May 28 19:44:54 NZST 2005


Every time it happens to me I'm in X and I can't move back to a console
to see any thing.  It is certainly frustrating because Linux is usually
so reliable.  I've not noticed anything relating to large IO though as
you are experiencing.  Just USB related stuff.  

In fact I'm going to launch into a Linux/USB related rant.  USB,
particularly USB Storage, support in Linux has always been extremely
crap.  I've never really found it to be reliable.  It might not be
Linux's "fault".  It might be crappy cheap Taiwanese hardware that is
the problem but Windows seems to handle this cheap hardware much better
than Linux does.

Back in FC1/2.4 days my Casio Camera's USB docking station didn't work
right.  I could never get transfers from the camera to work reliably so
instead I used windows (which worked fine without Casio specific
drivers).  On 2.6 it seems to be much more reliable, thankfully.

Currently I'm having the vast majority of my problems with my USB2
external HDD.  It is based on a Prolific Technology USB ATAPI-6 Bridge
Controller which Linux treats as a SCSI device (as it does with all USB
Storage devices).  Often if I unmount and unplug (or power down) the
drive I can't get it to re-initialise the next time I want to use it.
Linux just refuses to detect the device or if it does it just spits out
error messages.  Sometimes I can remove all the USB kernel modules and
reinsert them and the kernel recovers.  Other times it "half" works, the
bus detects the device but mount just locks up trying to mount the VFAT
file system on the HDD. And as I've previously stated other times the
whole machine just locks up a few seconds after I've removed the device
from the system.

On the whole, fucking crap.  Perhaps one day we'll have decent USB
storage support in Linux.  Until that day I'll just continue to bitch as
I don't have the knowledge to fix it myself. *sigh*

The only reason I even want to turn off my external HDD most of the time
is because when idle it makes this annoying ticking noise every few
minutes that lasts for about 20 seconds.  Almost like it is scanning the
hard disk for some reason.  I have no idea why it does this but it bugs
me.

Regards

On Sat, 2005-05-28 at 16:15 +1000, Raymond Burgess wrote:
> Oliver,
> 
> I initially tought it might just be X locking up, so I tried the copy 
> from the Console and noticed the stack dump.
> 
> Switched back to 2.6.9 this morning, copied around 200 GB of data, and 
> since that worked I was able to add the 200GB drive back into the 
> degradded Raid 5 array which rebuilt fine.
> 
> Run memtest over night a few times to test the ram, but I'm blaming the 
> kernel package as I have not had an issue all day, the machine only 
> lasted 5 minutes (under load) with the newer kernel.
> 
> Would be nice to know what exactly the problem is but I have no leads at 
> this stage.  I am using two different IDE controllers in this machine so 
> it might be a driver issue in the newer kernel.
> 
> Ray

--
                   Oliver Jones » Roving Code Warrior
   oliver@d... » +64 (21) 41 2238 » www.deeperdesign.com 




More information about the wlug mailing list
NOTICE: This is an archive of a public mailing list. The University of Waikato is not responsible for its contents.

The University of Waikato - Te Whare Wananga o Waikato