University Crest

[wlug] NAT rule entry for DSL-302G modem

 
wlug archive index About the wlug list Mailing lists home
To The University of Waikato HomepageWaikato Home > Waikato Mailing Lists > wlug Info > wlug archives
Leslie Katz lesliek@o...
Wed Nov 16 19:13:10 NZDT 2005


I'm sorry to bother people about this again. What I thought was a 
solution to an earlier problem turns out not to have been a permanent one.

I wanted to open some ports in the above modem, but couldn't access 
the modem's internal web server using Firefox for Linux. I was, 
however, able to do so using Internet Explorer (on my dual-boot 
computer) and to create an appropriate NAT rule. Then, when I 
restarted the computer and booted into Linux, the rule I'd created in 
Windows persisted in Linux.

However, when I later powered the computer (and modem) down and then 
powered up again, the rule I'd created was gone.

Since the WLUG wiki page on the modem referred to using the CLI and 
to some material about doing so, I got that material and studied it. 
I then did the following:

- booted into Windows;
- (re)created my NAT rule via the Web interface;
- restarted in Linux;
- tested the rule, which worked;
- opened the CLI and issued the command to get me the rule, which worked;
- issued the command to delete the rule, which worked;
- issued the command to (re)create the rule, which failed.

Here's the output:


                          *******************
                          Welcome to Titanium
                          *******************

D-Link Corp., Software Release R2.01M.B34.AU(021206a/T93.3.44)
Copyright (c) 2001-2002 by D-Link Corp.

login: admin
password:
Login Successful
$get nat rule entry ruleid 2

Rule Id          : 2                   Flavor           : REDIRECTION
Interface        : ALL                 Protocol         : ANY
Local addr from  : 10.1.1.3            Local addr to    : 10.1.1.3
Dest addr from   : 0.0.0.0             Dest addr to     : 255.255.255.255
Global addr from : 0.0.0.0             Global addr to   : 0.0.0.0
Dest port from   : 5235                Dest port to     : 5237
Local port       : 0
$delete nat rule entry ruleid 2

Entry Deleted
$create nat rule entry ruleid 2 rdr destportfrom 5235 destportto 5237 
lcladdrfro
m 10.1.1.3 lcladdrto 10.1.1.3
Error: Invalid command
$

I then rebooted into Windows and tried to (re)create the rule via 
telnet. Again, I got the invalid command message. I then tried simply 
to create a rule which appeared in the material about using the CLI. 
It wouldn't work either.

If anyone can give any suggestion about what I'm doing wrong, I'd be 
very grateful.

Thanks.

I don't know what I'm doing wrong.




More information about the wlug mailing list
NOTICE: This is an archive of a public mailing list. The University of Waikato is not responsible for its contents.

The University of Waikato - Te Whare Wananga o Waikato