University Crest

[wlug] Problem Installing Democracy Player

 
wlug archive index About the wlug list Mailing lists home
To The University of Waikato HomepageWaikato Home > Waikato Mailing Lists > wlug Info > wlug archives
Ian McDonald ian.mcdonald@j...
Thu Sep 14 13:09:16 NZST 2006


On 9/14/06, Craig Box <craig@d...> wrote:
> > [root@l... gtk-x11]# ./run.sh
> > Traceback (most recent call last):
> > File "setup.py", line 46, in ?
> > from Pyrex.Distutils import build_ext
> > ImportError: No module named Pyrex.Distutils [root@l... gtk-x11]#
> >
> > I don't understand how to overcome the problem disclosed.
> >
> > I thought that it might be possible for me to get an RPM which was or
> > included Pyrex.Distutils, but I couldn't find such an RPM. I then
> > Googled on Pyrex.Distutils, but, to be blunt, what I read was beyond
> > me.
>
> Try 'yum install pyrex'.
>
> Or upgrade.  Upgrading is good.
>
> Craig
>
The website indicates Fedora 4 and 5 support - doesn't talk about
earlier. Here are release notes from:
https://develop.participatoryculture.org/projects/democracy/wiki/LinuxNotes

Setting up on FEDORA ¶

    * On Fedora Core, you will probably require the following packages:

boost xine-lib xine-lib-devel libfame gnome-python2-gtkmozembed
gnome-python2-gconf mozilla-browser mozilla-psm

    * The gnome-python packages are available from Fedora itself, but
the other two must be found elsewhere. We suggest rpm.livna.org. This
is quite easy to do using yum. (You must be root or use sudo to run
the following commands.)

    * Note, using yum with multiple non-fedora repositories may cause
your machine to be rendered unusable. For some information on this,
check out

http://stanton-finley.net/fedora_core_5_installation_notes.html#Warning

    *
          o On Fedora Core 4:

rpm -ivh http://rpm.livna.org/livna-release4.rpm

    *
          o On Fedora Core 5:

rpm -ivh http://rpm.livna.org/livna-release-5.rpm

    *
          o If you're not using yum, more information is available at

http://rpm.livna.org/configuration.html

    * Then, you can use yum to install the needed packages with the
following command: (You must be root or use sudo to run the following
command.)

yum install boost xine-lib xine-lib-devel libfame
gnome-python2-gtkmozembed gnome-python2-gconf mozilla-browser
mozilla-psm



-- 
Ian McDonald
Web: http://wand.net.nz/~iam4
Blog: http://imcdnzl.blogspot.com
WAND Network Research Group
Department of Computer Science
University of Waikato
New Zealand




More information about the wlug mailing list
NOTICE: This is an archive of a public mailing list. The University of Waikato is not responsible for its contents.

The University of Waikato - Te Whare Wananga o Waikato