University Crest

[wlug] Problem Installing Democracy Player

 
wlug archive index About the wlug list Mailing lists home
To The University of Waikato HomepageWaikato Home > Waikato Mailing Lists > wlug Info > wlug archives
Leslie Katz lesliek@o...
Thu Sep 14 16:34:01 NZST 2006


Thanks to both of you for your replies.

I should've said in my original post that I had already installed pyrex, 
without overcoming the error message about Pyrex.Distutils by doing so. 
I apologise for that omission, which was caused by my being a bit flustered.

However, something written by Dominic reminded me of an earlier occasion 
on which I sought help on this list regarding a python script. The 
person who kindly helped me then pointed out that installing python2.4, 
while not uninstalling python2.3, wouldn't, of itself, help me to run a 
script that said it required python2.4. Python2.3 was being used as the 
default version on my system, so that I had to force the script to use 
python2.4. When I did that, the script worked.

Since Dominic had told me that the Pyrex scripts should appear in 
/usr/lib/python2.4/site-packages, I went looking, not there, but in 
/usr/lib/python2.3/site-packages. Sure enough, that's where they'd been 
installed. I therefore copied Pyrex/ into 
/usr/lib/python2.4/site-packages and re-ran run.sh.

On that attempt, there was no longer a complaint about the absence of 
the module Pyrex.Distutils. Instead, I got a different complaint further 
into the setup script, as follows:

Traceback (most recent call last):
  File "setup.py", line 175, in ?
    packages = getCommandOutput("pkg-config --list-all")
  File "setup.py", line 124, in getCommandOutput
    raise RuntimeError("%s outputted the following error:\n%s" %
RuntimeError: pkg-config --list-all outputted the following error:
Package dbus-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `dbus-1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'dbus-1', required by 'NetworkManager', not found

I went looking on my system for RPMS with dbus in their name and found I 
had four of them. One in particular was called 
dbus-python-0.22-10.FC3.2.i386.rpm and I assumed it was the relevant 
one. I got a list of all the files in that package. There were six of 
them: dbus.py; dbus.pyc; dbus.pyo; dbus_bindings.a; dbus_bindings.la; 
and dbus_bindings.so.

I went looking for those six files and found them all in 
/usr/lib/python2.3/site-packages.

I therefore tried the same trick as I'd tried with the Pyrex directory, 
namely, copying all six files into /usr/lib/python2.4/site-packages, but 
the trick would only work once. When I re-ran run.sh, I still got the 
same error message I set out above. (It's those files with "binding" in 
their names that are causing the trouble, I suspect.)

My current question, therefore, is how do I get into 
/usr/lib/python2.4/site-packages copies of the dbus-python rpm's files 
that will work?

One last thing. Craig raised a wry smile on my face by telling me 
upgrading was good. I've been wanting to upgrade for ages, but I'm too 
afraid. What I really need is a step-by-step guide in words of one 
syllable, explaining to me how to prepare for an upgrade, so that, after 
upgrading, I'll still have all my current data, my applications that 
I've separately installed and my settings for my current applications. 
Without that security blanket, I feel I'm stuck with FC3 indefinitely.

Thanks again,

Leslie




More information about the wlug mailing list
NOTICE: This is an archive of a public mailing list. The University of Waikato is not responsible for its contents.

The University of Waikato - Te Whare Wananga o Waikato